Network Performance Issues in Germany

Incident Report for Gather

Resolved

The issue has now been resolved. Please try loading into your space again.
Posted Jun 23, 2023 - 10:19 UTC

Monitoring

Our cloud provider is experiencing degraded performance for some users in Germany. They have implemented a fix and we are monitoring the situation.
Posted Jun 23, 2023 - 08:58 UTC