This issue has been resolved and space access has been restored. If you encountered issues with joining your space, please refresh and try again. If you are still encountering errors, please reach out to support@gather.town for further assistance.
Posted Apr 27, 2026 - 21:23 UTC
Monitoring
We're beginning to see recovery for the affected users, and are continuing to monitor.
If you encountered issues with joining your space, please refresh and try again.
Posted Apr 27, 2026 - 20:48 UTC
Update
Engineers are continuing to investigate potential causes of the incident
Posted Apr 27, 2026 - 19:21 UTC
Investigating
We understand that some spaces are unable to be accessed. The engineering team is aware and investigating the issue