Issues with latest Desktop App Update

Incident Report for Gather

Resolved

We have released a new version of the desktop app (0.3.20) which should resolve the reported installation issues - thank you for bearing with us! Download it here: https://www.gather.town/download
Posted Nov 10, 2022 - 20:42 UTC

Investigating

We've received reports that the latest update of the Desktop app for Windows is not installing appropriately for some users. Our engineering team is investigating.
Posted Nov 10, 2022 - 16:35 UTC
This incident affected: Desktop Application (beta).