Issues with game server

Incident Report for Gather

Resolved

This incident is now resolved. Thank you for your patience!
Posted Apr 12, 2022 - 05:48 UTC

Investigating

Seeing issues with gamer server. Sorry for the disruption!
Posted Apr 12, 2022 - 05:37 UTC