Fail to load Gather Homepage
Incident Report for Gather
Resolved
We think the impact from the issue is over.
Posted Dec 15, 2023 - 23:29 UTC
Investigating
We've spotted that something has gone wrong and users are having issues loading Gather home page. We're currently investigating the issue, and will provide an update soon.
Posted Dec 15, 2023 - 22:24 UTC