This issue has been resolved and space access has been restored. If you encountered issues with joining your space, please refresh and try again.
If you are still encountering errors, please reach out to support@gather.town for further assistance.
Posted Apr 07, 2026 - 16:38 UTC
Monitoring
We have released a fix for the issue that was blocking users from accessing their spaces. Please refresh and try to enter again.
We're still monitoring this issue and will send a final update soon.
Posted Apr 07, 2026 - 16:12 UTC
Investigating
We've spotted that something has prevented some users from joining spaces. Our engineers are aware and are currently investigating the issue, and will provide an update soon.